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Why Examine Your Data?

Applying multivariate techniques Applying multivariate techniques 
indiscriminately can:indiscriminately can:

further separate researcher from understanding further separate researcher from understanding 
the datathe data
lead to exaggerated claims of lead to exaggerated claims of ““quick and easyquick and easy””
solutionssolutions
produce invalid results due to violated produce invalid results due to violated 
assumptionsassumptions

Researcher should endeavor to recognize Researcher should endeavor to recognize 
potential problems as they occur, and apply potential problems as they occur, and apply 
appropriate remediesappropriate remedies

3

Benefits of Examining Data

Enables basic understanding of data and Enables basic understanding of data and 
relationships amongst variables, particularly relationships amongst variables, particularly 
graphicallygraphically
Insurance against catastrophic errorsInsurance against catastrophic errors
Prompts consideration of missing dataPrompts consideration of missing data
Alerts researcher to presence of potential outliersAlerts researcher to presence of potential outliers
Allows assessment of statistical assumptions Allows assessment of statistical assumptions 
underlying multivariate techniquesunderlying multivariate techniques
Leads to careful thought about representing Leads to careful thought about representing 
nonmetric datanonmetric data
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Reading Data Into SAS
All class datasets are available in Excel All class datasets are available in Excel 
spreadsheet formatspreadsheet format

Save Save hatco.xlshatco.xls from the class website to a from the class website to a 
folder in your home directoryfolder in your home directory

Start SASStart SAS
Select File > Import Data to open the spreadsheet Select File > Import Data to open the spreadsheet 
as a table in SASas a table in SAS

Select Browse to locate the Excel file you savedSelect Browse to locate the Excel file you saved
Type Type ““HatcoHatco”” (for example) as the Member (for example) as the Member 
name in the Work Libraryname in the Work Library

5

Distribution Shapes: Histograms
Analyzing Analyzing HatcoHatco data in SAS:data in SAS:
Solutions > Analysis > AnalystSolutions > Analysis > Analyst
File > Open By SAS Name (open File > Open By SAS Name (open HatcoHatco in the Work library)in the Work library)
Graphs > HistogramGraphs > Histogram

6

Relationships Between Variables
SAS: Graphs > Scatter Plot > TwoSAS: Graphs > Scatter Plot > Two--DimensionalDimensional
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Examining Group Differences
SAS: Graphs > Box PlotSAS: Graphs > Box Plot

medianmedian
2525thth percentilepercentile

7575thth percentilepercentile

maxmax

minmin
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Missing Data

Missing Data Process: systematic cause of missing Missing Data Process: systematic cause of missing 
values in samplevalues in sample
If not accounted for, can lead to biased results If not accounted for, can lead to biased results 
(individuals with missing values may be different (individuals with missing values may be different 
to those with complete data)to those with complete data)
If all cases with any missing values are excluded, If all cases with any missing values are excluded, 
sample size can be drastically reducedsample size can be drastically reduced
Need to either gather additional data or find Need to either gather additional data or find 
remedy for missing data in original sampleremedy for missing data in original sample
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Missing Data Processes
IgnorableIgnorable. Consider variables . Consider variables XX (no missing values) and (no missing values) and YY
(some missing values):(some missing values):

explicitly accommodated in analysis, e.g. censored data explicitly accommodated in analysis, e.g. censored data 
in survival analysis (in survival analysis (Y Y = survival time)= survival time)
missing completely at random (missing completely at random (MCARMCAR), i.e. values of ), i.e. values of 
YY are a random sample of all are a random sample of all YY valuesvalues
missing at random (missing at random (MARMAR), i.e. missing values of ), i.e. missing values of YY
depend on depend on XX but not on but not on YY

NonNon--ignorableignorable, i.e. missing data process related to missing , i.e. missing data process related to missing 
YY valuesvalues
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Diagnosing MCAR Processes

Compare Compare XX--values in two groups values in two groups –– those those 
with missing with missing YY--values, those with valid     values, those with valid     
YY--valuesvalues
Consider bivariate correlations between Consider bivariate correlations between 
missing value indicators for each variablemissing value indicators for each variable
Overall MCAR test available in specialized Overall MCAR test available in specialized 
softwaresoftware
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Dealing With Missing Data

If available, use a technique that explicitly If available, use a technique that explicitly 
accounts for missing data, e.g. survival accounts for missing data, e.g. survival 
analysisanalysis
If process is MAR or nonIf process is MAR or non--ignorable, consult ignorable, consult 
an expert!an expert!
If process is MCAR, use one of the If process is MCAR, use one of the 
following approachesfollowing approaches
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Approaches for MCAR data
Complete case approach (or listwise)Complete case approach (or listwise)
Delete cases and/or variablesDelete cases and/or variables
AllAll--available approach (e.g. pairwise correlation)available approach (e.g. pairwise correlation)
Replace missing data with imputed valuesReplace missing data with imputed values

Case substitutionCase substitution
Mean substitutionMean substitution
Cold deck imputationCold deck imputation
Regression imputationRegression imputation
Multiple imputationMultiple imputation

ModelModel--based (e.g. EM algorithm)based (e.g. EM algorithm)
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Outliers

Observations with distinctly different Observations with distinctly different 
combinations of characteristicscombinations of characteristics
Can be beneficial or problematicCan be beneficial or problematic
Identify and ascertain type of influenceIdentify and ascertain type of influence
Types of outlier:Types of outlier:

procedural errorprocedural error
result of an extraordinary eventresult of an extraordinary event
no known explanationno known explanation
values on each variable not unusual but values on each variable not unusual but 
combination of values is uniquecombination of values is unique
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Detecting Outliers

UnivariateUnivariate: consider values > 2.5 standard : consider values > 2.5 standard 
deviations from the meandeviations from the mean
BivariateBivariate: consider isolated points in : consider isolated points in 
scatterplotsscatterplots
Multivariate: consider observations which Multivariate: consider observations which 
have a very small have a very small pp--value on value on MahalanobisMahalanobis
DD22 testtest

~      , where ~      , where pp = # variables in = # variables in xx
)()( 12 xxSxx −−= −TD

2
pχ2D
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Dealing With Outliers

Once detected, profile to determine Once detected, profile to determine 
distinguishing features and classifydistinguishing features and classify
Decide to retain or delete:Decide to retain or delete:

if they represent a segment of the if they represent a segment of the 
population, retain to ensure population, retain to ensure 
generalizabilitygeneralizability
if truly aberrant, delete to avoid distorting if truly aberrant, delete to avoid distorting 
analysisanalysis
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Testing Assumptions

Assessing statistical assumptions particularly Assessing statistical assumptions particularly 
important in multivariate analysis:important in multivariate analysis:

Complex relationships compound effects of Complex relationships compound effects of 
assumption violationsassumption violations
Multivariate nature of the analysis can make Multivariate nature of the analysis can make 
assumption violations hard to spotassumption violations hard to spot

Test assumptions twice:Test assumptions twice:
PrePre--model, for each variable separatelymodel, for each variable separately
PostPost--model, for the multivariate model model, for the multivariate model variatevariate
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Normality

UnivariateUnivariate normality for each variable normality for each variable 
separately separately −− easily tested and correctedeasily tested and corrected
Multivariate normality for all variables Multivariate normality for all variables 
simultaneously simultaneously −− more difficult to assessmore difficult to assess
If If MNMN then then UNUN, but can be , but can be UNUN but not but not MNMN
Large samples can mitigate adverse effects Large samples can mitigate adverse effects 
of violating normality assumptionsof violating normality assumptions
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Graphical Analyses of Normality

Histogram with superimposed normal curveHistogram with superimposed normal curve
QQ--Q plot (or normal probability plot)Q plot (or normal probability plot)

Consider a standard normal distribution Consider a standard normal distribution 
with same number of observations as with same number of observations as 
sample datasample data
Draw a Draw a scatterplotscatterplot of observed data of observed data 
values (y) versus those for expected values (y) versus those for expected 
normal values (x) normal values (x) 
Do the points lie along a 45Do the points lie along a 4500 line?line?
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Example of a Q-Q Plot
SAS: Analyze > DistributionSAS: Analyze > Distribution
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Statistical Tests of Normality

Rules of thumb:Rules of thumb:
skewnessskewness / (         ) ~ normal/ (         ) ~ normal
kurtosis / (           ) ~ normalkurtosis / (           ) ~ normal

KolmogorovKolmogorov--SmirnovSmirnov
ShapiroShapiro--WilksWilks (< 50 in sample)(< 50 in sample)
Beware indiscriminate use in small samples (< 30) Beware indiscriminate use in small samples (< 30) 
and large samples (>1000)and large samples (>1000)
Data transformations can improve normalityData transformations can improve normality

N/6
N/24
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Homoscedasticity

When a metric variable displays equal levels of When a metric variable displays equal levels of 
variance across the range of another variable variance across the range of another variable 
(metric or (metric or nonmetricnonmetric))
More generally concerns equal varianceMore generally concerns equal variance--
covariance matrices, e.g covariance matrices, e.g discriminantdiscriminant analysisanalysis
Unequal matrices results in Unequal matrices results in heteroscedasticityheteroscedasticity, for , for 
example:example:

larger dispersion in xlarger dispersion in x11 for larger values of xfor larger values of x22

skewnessskewness in xin x22 leads to varying dispersion in xleads to varying dispersion in x11
22

Assessing Homoscedasticity

BoxplotsBoxplots of metric variable for each value of a of metric variable for each value of a 
nonmetricnonmetric variablevariable
LeveneLevene test to assess equal variances of metric test to assess equal variances of metric 
variable across values of variable across values of nonmetricnonmetric variablevariable
BoxBox’’s s MM test to assess equality of variancetest to assess equality of variance--
covariance matrices in covariance matrices in discriminantdiscriminant analysisanalysis
Data transformations can also correct Data transformations can also correct 
heteroscedasticityheteroscedasticity
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Linearity

PearsonPearson’’s correlation measures the s correlation measures the linearlinear
association between two variablesassociation between two variables
Techniques based on correlations (e.g. logistic Techniques based on correlations (e.g. logistic 
regression) can miss any nonlinear effects in the regression) can miss any nonlinear effects in the 
datadata
Identify nonlinear patterns in Identify nonlinear patterns in scatterplotsscatterplots of of 
variables and residualsvariables and residuals
Data transformations can Data transformations can linearizelinearize nonlinear nonlinear 
relationshipsrelationships
Remaining nonlinear relationships can be modeledRemaining nonlinear relationships can be modeled
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Uncorrelated Errors

Prediction errors should not reveal systematic Prediction errors should not reveal systematic 
patterns, e.g. +, patterns, e.g. +, −−, +, , +, −−, , ……
Data collection process can result in correlated Data collection process can result in correlated 
errors, for example:errors, for example:

Two groups analyzed together, but each group Two groups analyzed together, but each group 
differs on a variable omitted from the modeldiffers on a variable omitted from the model
Any results are biased because an unspecified Any results are biased because an unspecified 
cause impacts the groups differentlycause impacts the groups differently
Remedy: identify the omitted factor and include Remedy: identify the omitted factor and include 
in the analysisin the analysis
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Data Transformations

Used to correct assumption violationsUsed to correct assumption violations
nonnon--normalitynormality
heteroscedasticityheteroscedasticity
linearitylinearity

Take the textbook guidelines with a pinch of salt, Take the textbook guidelines with a pinch of salt, 
e.g. negative skew can be turned into positive e.g. negative skew can be turned into positive 
skew by negating, then logarithm skew by negating, then logarithm oror square root square root 
can normalizecan normalize
Be careful with interpreting results after Be careful with interpreting results after 
transforming original data!transforming original data!
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Using Nonmetric Data

Create dummy/indicator variables (to represent Create dummy/indicator variables (to represent 
categories of categories of nonmetricnonmetric variable):variable):

indicator coding to represent deviations from a indicator coding to represent deviations from a 
comparison group (use 1comparison group (use 1’’s and 0s and 0’’s only) s only) 
effects coding to represent deviations from effects coding to represent deviations from 
mean over all groups (use 1mean over all groups (use 1’’s, 0s, 0’’s, and s, and −−11’’s) s) 

Require one fewer dummy variables than there are Require one fewer dummy variables than there are 
levels of the levels of the nonmetricnonmetric variablevariable
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Indicator Coding
Model:Model:

DD11 DD22

Low:Low: 00 00
Medium:Medium: 11 00
High:High: 00 11

Estimates:Estimates:

Low:Low:
Medium:Medium:
High:High:

and      represent and      represent 
““deviations from the Low deviations from the Low 
categorycategory””

means we means we 
predict the response for predict the response for 
the Medium category to be the Medium category to be 
5 units lower than the Low 5 units lower than the Low 
category (7 category (7 −− 5 = 2)5 = 2)

means we means we 
predict the response for predict the response for 
the High category to be 4 the High category to be 4 
units lower than the Low units lower than the Low 
category (7 category (7 −− 4 = 3)4 = 3)

22110)( DDyE βββ ++=

4,5,7 210 −=−== βββ

210 =+ ββ
320 =+ ββ

70 =β

1β 2β

51 −=β

42 −=β
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Effects Coding
Model:Model:

DD11 DD22

Low:Low: 11 00
Medium:Medium: 00 11
High:High: −−11 −−11

Estimates:Estimates:

Low:Low:
Medium:Medium:
High:High:
““averageaverage””::

,       , and           ,       , and           
represent represent ““deviations from deviations from 
the averagethe average””

means we predict means we predict 
the response for Low to be the response for Low to be 
3 units higher than average 3 units higher than average 
(4 + 3 = 7)(4 + 3 = 7)

means we predict means we predict 
the response for Medium to the response for Medium to 
be 2 units lower than be 2 units lower than 
average (4 average (4 −− 2 = 2)2 = 2)

means we means we 
predict the response for predict the response for 
High to be 1 unit lower High to be 1 unit lower 
than average (4 than average (4 −− 1 = 3)1 = 3)

22110)( DDyE ηηη ++=

2,3,4 210 −=== ηηη
710 =+ηη
220 =+ηη
3210 =−− ηηη

1η 2η

31 =η

22 −=η

21 ηη −−

121 −=−− ηη

40 =η

29

Effects Coding for Jobs Example
Location:Location:
Eugene =Eugene = 1 if Eugene1 if Eugene

−−1 if Denver1 if Denver
0 otherwise0 otherwise

Portland =Portland = 1 if Portland1 if Portland
−−1 if Denver1 if Denver
0 otherwise0 otherwise

Seattle =Seattle = 1 if Seattle1 if Seattle
−−1 if Denver1 if Denver
0 otherwise0 otherwise

i.e. stimuli with Denver are i.e. stimuli with Denver are −−1 1 
on these three dummy variableson these three dummy variables

Salary:Salary:
50K =50K = 1 if 50K1 if 50K

−−1 if 80K1 if 80K
0 otherwise0 otherwise

60K =60K = 1 if 60K1 if 60K
−−1 if 80K1 if 80K
0 otherwise0 otherwise

70K =70K = 1 if 70K1 if 70K
−−1 if 80K1 if 80K
0 otherwise0 otherwise

i.e. stimuli with 80K are i.e. stimuli with 80K are −−1 on 1 on 
these three dummy variablesthese three dummy variables


